- forgot to remove autogen.sh previously along with the rest of the autotools
[freeglut] / freeglut.spec
1 #
2 # spec file for package freeglut (Version 2.6.0)
3 #
4 # Copyright (c) 2005 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 # This file and all modifications and additions to the pristine
6 # package are under the same license as the package itself.
7 #
8 # Please submit bugfixes or comments via http://www.suse.de/feedback/
9 #
10
11 # norootforbuild
12 # usedforbuild    Mesa Mesa-devel aaa_base acl attr audit-libs autoconf automake bash bind-libs bind-utils binutils bison bzip2 coreutils cpio cpp cracklib cvs cyrus-sasl db diffutils e2fsprogs expat file filesystem fillup findutils flex fontconfig fontconfig-devel gawk gcc gcc-c++ gdbm gdbm-devel gettext gettext-devel glibc glibc-devel glibc-locale gpm grep groff gzip info insserv klogd less libacl libattr libcom_err libdrm libdrm-devel libgcc libnscd libstdc++ libstdc++-devel libtool libxcrypt libzio m4 make man mktemp module-init-tools ncurses ncurses-devel net-tools netcfg openldap2-client openmotif-libs openssl pam pam-modules patch perl permissions popt procinfo procps psmisc pwdutils rcs readline rpm sed strace sysvinit tar tcpd texinfo timezone unzip util-linux vim xorg-x11-devel xorg-x11-libs zlib zlib-devel
13
14 BuildRequires:  Mesa-devel gcc-c++ libdrm-devel
15
16 Name:         freeglut
17 Summary:      Freely Licensed Alternative to the GLUT Library
18 Version:      2.6.0
19 Release:      1
20 URL:          http://freeglut.sourceforge.net/
21 Source0:      http://switch.dl.sourceforge.net/sourceforge/freeglut/freeglut-%{version}.tar.gz
22 # NOTE: SuSE adds the original GLUT man pages. If you don't have the file
23 # below, comment that line out and remove "-b1" from the setup macro.
24 Source1:      glutman.tar.bz2
25 License:      X11/MIT
26 Provides:     mesaglut
27 Obsoletes:    mesaglut
28 Group:        System/Libraries
29 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
30
31 %description
32 freeglut is a completely Open Source alternative to the OpenGL Utility
33 Toolkit (GLUT) library. GLUT was originally written by Mark Kilgard to
34 support the sample programs in the second edition OpenGL Redbook. Since
35 then, GLUT has been used in a wide variety of practical applications
36 because it is simple, universally available, and highly portable.
37
38 GLUT (and freeglut) allow the user to create and manage windows
39 containing OpenGL contexts and also read the mouse, keyboard, and
40 joystick functions on a wide range of platforms.
41
42
43
44 Authors:
45 --------
46     Pawel W. Olszta
47     Andreas Umbach
48     Steve Baker
49
50 %package devel
51 Summary:      Development Package for freeglut (GLUT Library)
52 Group:        Development/Libraries/X11
53 Requires:     %{name} = %{version}-%{release}
54 Provides:     mesaglut-devel
55 Obsoletes:    mesaglut-devel
56
57 %description devel
58 Freeglut (GLUT library) development package.
59
60
61
62 %debug_package
63 %prep
64 %setup -q -b1
65
66 %build
67 ./autogen.sh
68 CFLAGS="$RPM_OPT_FLAGS" \
69   ./configure --prefix=/usr --libdir=%_libdir
70 make %{?jobs:-j%jobs}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %makeinstall 
76 # GLUT manual pages
77 touch man-pages
78 if test -d ../glut-3.7 ; then
79   mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man3
80   dir=`pwd`
81   pushd ../glut-3.7
82     for i in man/glut/glut*; do
83       install -m 644 $i ${RPM_BUILD_ROOT}/%{_mandir}/man3/`basename $i man`3
84       gzip -9 ${RPM_BUILD_ROOT}/%{_mandir}/man3/`basename $i man`3
85       echo %{_mandir}/man3/`basename $i man`3.gz >> ${dir}/man-pages
86     done
87   popd
88 fi
89
90 %post
91 %run_ldconfig
92
93 %postun
94 %run_ldconfig
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(-,root,root)
101 %{_libdir}/libglut.so.*
102
103 %files devel -f man-pages
104 %defattr(-,root,root)
105 %{_includedir}/GL/*
106 %{_libdir}/libglut.a
107 %{_libdir}/libglut.la
108 %{_libdir}/libglut.so
109
110 %changelog -n freeglut
111 * Sun Apr 05 2009 - sven.panne@aedion.de
112 - updated to release 2.6.0
113 * Sat Aug 05 2006 - sven.panne@aedion.de
114 - Updated build requirements for SuSE 10.1
115 * Mon Jun 13 2005 - sven.panne@aedion.de
116 - updated to release 2.4.0
117 - use autogen.sh
118 - no need to remove demos
119 - conditionalized handling of GLUT manual pages
120 * Thu Apr 29 2004 - coolo@suse.de
121 - build parallel if available
122 - build as user
123 * Mon Dec 15 2003 - sndirsch@suse.de
124 - updated to release 2.2.0
125   * Mousewheel Support for Win32 & X11
126   * More unified Win32/*nix behavior and code
127   * Code style cleanups
128   * Visibility support in Win32
129   * Many other Good Bug Fixes
130 * Sat Dec 06 2003 - sndirsch@suse.de
131 - updated to release 2.0.1
132   * fixes a number of bugs with menus
133 * Fri Oct 10 2003 - adrian@suse.de
134 - fix build for mips
135 - satisfy configure checks
136 * Thu Oct 02 2003 - sndirsch@suse.de
137 - provides/obsoletes mesaglut/mesglut-devel now
138 * Tue Sep 30 2003 - sndirsch@suse.de
139 - removed demos
140 * Tue Sep 30 2003 - sndirsch@suse.de
141 - added GLUT manual pages
142 * Mon Sep 29 2003 - sndirsch@suse.de
143 - updated to final release 2.0.0
144 * Thu Aug 14 2003 - sndirsch@suse.de
145 - added GameMode fix (GameModeFixes-4.dif)
146 * Thu Aug 07 2003 - sndirsch@suse.de
147 - created package